Follow

What versions of Flash can I use to play Gardens of Time?

Currently Gardens of Time supports Flash versions 11.4 and newer. 

We do apologize, but this version of Flash is not available on some older operating systems, such as Snow Leopard, and some versions of Linux. 

 

For Flash Player Help, please see Adobe's Flash Help Center

http://helpx.adobe.com/flash-player.html

 

If you play Gardens of Time on Google Chrome, you will need to use the default version of Flash that updates itself. 

If you believe you may have accidentally installed a different version, or otherwise need more information, please see the article below:

http://gardensoftime.rockyou.com/faq/?cat=Technical

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments